måndag 10 juni 2013

Installera Pirateplayer i Ubuntu/Debian

Skaffa rätt debianpaket Nedan följer en lista över färdigbyggda debianpaket för Pirateplayer 0.5.0 Qt Desktop Components och libtidy-gitversion. Ladda ner de som hör till din version av Ubuntu/Debian. Finns inte din version kan du testa med den version som ligger närmast. Fungerar det ändå inte kan du kompilera Pirateplayer själv.

Installera beroenden

  1. sudo add-apt-repository ppa:jon-severinsson/ffmpeg
  2. sudo apt-get update
  3. sudo apt-get upgrade -y
  4. sudo apt-get install libqtcore4 libqtgui4 \ libqt4-xml libqt4-network libqt4-declarative libqt4-script \ libqt4-xmlpatterns libqt4-svg libqtwebkit4 rtmpdump librtmp0 \ ffmpeg xsltproc -y

Installera Qt Desktop Components

Precise, Oneiric, Natty, Maverick eller Lucid: Forum Nokia PPA

Kör följande kommandon om du använder Precise, Oneiric, Natty, Maverick eller Lucid:
  1. sudo add-apt-repository ppa:forumnokia/fn-ppa
  2. sudo apt-get update
  3. sudo apt-get install qt-components-desktop -y

Övriga

Kör du en nyare versin av Ubuntu än ovan listade versioner? Givet att du laddade ner qt-components-desktop-paketet under "Skaffa rätt debianpaket", kör:
  1. sudo dpkg -i qt-components-desktop_[version]-git-1_[arkitektur].deb

Installera Libtidy och Pirateplayer

Ersätt [version] och [arkitektur] i kommandona nedan så de stämmer överens med de filnamnen för de debianpaket du laddade ner tidigare.
  1. sudo apt-get remove libtidy*
  2. sudo dpkg -i libtidy_[version]-git-1_[arkitektur].deb
  3. sudo dpkg -i pirateplayer_0.5.0-1_[arkitektur].deb
Pirateplayer bör nu vara installerat!
Skicka en kommentar